#!/bin/sh

# Slackware build script for netbeans

# Copyright (c) 2008-2009, Antonio Hernández Blas <hba.nihilismus@gmail.com>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions are met:
# 1.- Redistributions of source code must retain the above copyright
#     notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
# DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
# DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# This script is just a binary repackaging.

## Patched to pass Salix' packaging rules - R. Groner <raphgro(at)web.de>
## ChangeLog:
## 1/            Adopted from slackbuilds.org
## 2/2010-01-04  Add a symlink for and moved application icon
##               Removed some nonsense code :D
## 3/2010-01-16  Fixed location and symlinking of configuration
##               files (gapan)


PRGNAM=netbeans
VERSION=6.8
DATE="200912091457"  ## community contributions
ARCH=noarch
BUILD=${BUILD:-1}
TAG=${TAG:-rg}
PKGTYPE=${PKGTYPE:-txz}

CWD=$(pwd)
TMP=${TMP:-$CWD}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-$CWD}

DOC=/usr/doc
LIB=/usr/lib
ETC=/etc
BIN=/usr/bin

set -e

rm -rf $PKG
mkdir -p $TMP $PKG$DOC/$PRGNAM-$VERSION $PKG$LIB/$PRGNAM $PKG$ETC $PKG$BIN $OUTPUT
cd $PKG$LIB
unzip -o $CWD/$PRGNAM-$VERSION-$DATE-ml.zip
chown -R root:root .

find . \
 \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

# Add netbeans to KDE/GNOME/XFCE menu
install -D -m 0644 $CWD/$PRGNAM.desktop \
  $PKG/usr/share/applications/$PRGNAM.desktop

# Add an icon for netbeans
install -D -m 0644 $CWD/$PRGNAM.png \
  $PKG/usr/share/icons/hicolor/32x32/apps/$PRGNAM.png 
mkdir -p $PKG/usr/share/pixmaps
ln -s ../icons/hicolor/32x32/apps/$PRGNAM.png  \
  $PKG/usr/share/pixmaps/$PRGNAM.png 

# Add an script to call netbeans from $BIN.
cat <<- EOF > $PKG$BIN/$PRGNAM
#!/bin/sh
cd $LIB/$PRGNAM/bin
./netbeans \$@
EOF
chmod 0755 $PKG$BIN/$PRGNAM

( cd $PKG
  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
    xargs strip --strip-unneeded 2> /dev/null || true
  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
    xargs strip --strip-unneeded 2> /dev/null
)

# Put config files under /etc and create symlinks to where netbeans is
# going to look for them
mkdir -p $PKG$ETC/$PRGNAM
mv $PKG$LIB/$PRGNAM/etc/* $PKG$ETC/$PRGNAM/
(
cd $PKG$LIB/$PRGNAM/etc
for i in `ls $PKG$ETC/$PRGNAM`; do
	ln -s $ETC/$PRGNAM/$i $i
done
)
# Don't replace existing config files
find $PKG$ETC/$PRGNAM/ -type f -exec mv {} {}.new \;

cd $PKG$LIB/$PRGNAM
mv *.html *.txt *.css $PKG$DOC/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG$DOC/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cp $CWD/README $CWD/community.txt $PKG$DOC/$PRGNAM-$VERSION

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE