#!/bin/sh
# Copyright 2009 George Vlahavas
# All rights reserved.
#
# Heavily based on the Slackware 12.2 SlackBuild
#
# http://www.swiss.csail.mit.edu/~jaffer/SLIB.html
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

CWD=`pwd`
TMP=${TMP:-/tmp/tgz}
PKG=$TMP/package-slib
NAME=slib
VERSION=3b2
ARCH=${ARCH:-noarch}
BUILD=1gv

SOURCE=http://swiss.csail.mit.edu/ftpdir/scm/$NAME-$VERSION.zip

if [ ! -e $NAME-$VERSION.zip ]; then
wget -c $SOURCE
fi


if [ ! -d $TMP ]; then
 mkdir -p $TMP
fi
if [ ! -d $PKG ]; then
 mkdir -p $PKG
fi

cd $TMP
unzip $CWD/$NAME-$VERSION.zip
cd $NAME
find . \( -perm 777 -o -perm 775 -o -perm 711 \) -exec chmod 755 {} \;
find . \( -perm 700 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \;
find . \( -perm 666 -o -perm 664 -o -perm 600 \) -exec chmod 644 {} \;
find . \( -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
chown -R root:root .
mkdir -p $PKG/usr/info
make prefix=$PKG/usr/ infoz
make prefix=$PKG/usr/ install
mkdir -p $PKG/usr/doc/$NAME-$VERSION
cp -a ANNOUNCE COPYING ChangeLog FAQ README $PKG/usr/doc/$NAME-$VERSION
rm $PKG/usr/info/dir
find $PKG/usr/man -type f -exec gzip -9 {} \;
cd ..
rm $NAME/{ANNOUNCE,COPYING,ChangeLog,FAQ,README}
mkdir -p $PKG/usr/share/guile
mv $NAME $PKG/usr/share/guile
sed -i "s|/tmp/tgz/package/usr/|/usr/|g" $PKG/usr/bin/slib
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh
cat $CWD/slack-desc > $PKG/usr/doc/$NAME-$VERSION/slack-desc
cat $CWD/$NAME.SlackBuild > $PKG/usr/doc/$NAME-$VERSION/$NAME.SlackBuild
cd $PKG
/sbin/makepkg -l y -c n $CWD/$NAME-$VERSION-$ARCH-$BUILD.txz

if [ "$1" = "--cleanup" ]; then
 rm -rf $TMP
fi